Fichiers texte multilingues et textes délimités
Utilisez ce filtre pour importer des fichiers Excel,CSV ou autres fichiers texte avec des valeurs séparées par des virgules ou des tabulations contenant plusieurs langues dans les colonnes.
Chaque segment contient des textes liés et chaque colonne définit ce que le texte représente (par exemple, texte source ou traduction).
Vous pouvez définir la façon dont memoQ importe le texte de chaque colonne dans les langues source et cible du projet. Si vous avez une licence Chef de projet, vous pouvez également exporter plusieurs langues cibles en une seule fois, dans un seul fichier d’exportation.
Pour simplifier les choses, le filtre indique CSV, mais prend également en charge d’autres formats délimités.
Vous ne pouvez pas importer un fichier Excel ou texte multilingue dans une base LiveDocs.
Comment se rendre ici
-
Commencez à importer un fichier Excel multilingue ou un fichier texte.
-
Dans la fenêtre Options d’importation de documents, sélectionnez les fichiers Excel ou texte, et cliquez sur Modifier le filtre & configuration.
-
La fenêtre Paramètres d’importation de document apparaît. Dans la liste déroulante Filtrer, choisissez filtre de texte délimité multilingue.
Par défaut, memoQ n’importe pas les nombres ni les formules des fichiers Excel. Pour les importer, utilisez l’onglet des options Excel.
Que pouvez-vous faire?
Les paramètres sont un peu différents pour les fichiers Excel et pour les fichiers CSV ou les fichiers séparés par des tabulations.
Dans l’onglet Format de base, choisissez entre Excel et séparé par des virgules ou des tabulations.
Si vous traduisez dans une seule langue cible: Cochez la case de configuration simple bilingue, et travaillez avec les colonnes en bas de la fenêtre. Pour plus de détails, consultez la section Traitement des colonnes.
Sous la section Segmentation, vous pouvez:
-
Utiliser la segmentation basée sur les règles de langue:
-
Ne – memoQ ne divise pas les éléments
<segment>selon les règles linguistiques. Ceci est l’option par défaut. -
Lorsqu’il n’y a aucune cible, memoQ divise les éléments
<segment>qui ne comportent aucun élément<target>, selon les règles linguistiques. -
Uniquement lorsque le nombre de segments dans la source et la cible est identique: memoQ divise les éléments
<segment>qui comportent des éléments<target>lorsque la source et la cible ont le même nombre de segments.Avez-vous besoin de plus d’information? Lisez la régle de segmentation dans memoQ.
-
-
Segment sur saut de ligne - commencer un nouveau segment chaque fois qu’il y a un saut de ligne dans la cellule (Excel seulement).
-
Inclure un saut de ligne manuel en tant que balise interne - insérer une balise interne pour chaque saut de ligne manuel dans la cellule (insérer dans Excel avec Alt+Entrée).
-
Sur l’onglet format de base, cliquez sur le bouton radio Excel.
-
Cliquez sur l’onglet Options Excel.
Vous pouvez définir les éléments suivants:
Vous pouvez importer du contenu qui est formaté – ou non formaté – avec des couleurs de fond spécifiques.
Cliquez sur un bouton radio
-
Ne pas importer si la couleur de fond est: Il s’agit du paramètre par défaut. memoQ ignore les cellules mises en forme avec les couleurs d’arrière-plan indiquées.
-
Importer uniquement si la couleur de fond est: Si vous choisissez cette option, memoQ importe uniquement les cellules mises en forme avec les couleurs d’arrière-plan indiquées.
Ajouter des couleurs à la boîte ci-dessous les boutons radio:
-
Tapez un code de couleur dans le champ de texte RGB, puis cliquez sur Ajouter.
Le code couleur est un nombre hexadécimal à six chiffres: les deux premiers chiffres sont pour le bleu, le troisième et quatrième pour le vert, et les deux derniers sont pour le rouge. Par exemple, le code 00FF00 représente vert pur.
OU
-
Choisir la couleur dans Excel.
-
Cliquez sur la sélection dans Excel. memoQ ouvre le document source dans Excel (Excel doit être installé). Alors la fenêtre Ajouter des couleurs à partir d’un fichier apparaît:
-
Dans Excel, sélectionnez une plage qui contient les couleurs de fond que vous souhaitez utiliser. Puis cliquez sur Ajouter des couleurs à partir d’une sélection. Les couleurs apparaissent sur la liste dans la fenêtre des paramètres d’importation de document.
-
Ajouter plus de couleurs à la liste: Répétez l’étape 2.
-
Cliquez sur Terminer. Cela ferme la fenêtre Ajouter des couleurs à partir de la fenêtre des fichiers, ainsi qu’Excel.
Pour supprimer une couleur de la liste : Sélectionnez la couleur, puis cliquez sur Supprimer.
-
Vous pouvez également :
-
Pour importer du texte à partir de feuilles de calcul masquées, cochez la case Inclure masquées.
-
Pour importer le texte des segments masqués, sélectionnez la case à cocher Inclure.
-
Pour importer des nombres ou des formules dans les segments source et cible : Cochez la case Inclure les cellules des formules ou des nombres.
-
Pour conserver la formule ou le nombre précédent dans le segment cible, désélectionnez la case à cocher « Écraser les » si un segment cible n’a pas été inclus.
Cette option est utile lorsque les segments cibles contiennent déjà des nombres ou des formules (différents). Par défaut, memoQ remplace ces valeurs en copiant le nombre ou la formule (ou le texte) du segment source.
-
Pour conserver la mise en forme supplémentaire dans les cellules, cochez la case Maintenir la mise en. memoQ exportera les traductions (et le texte source) avec la même mise en forme que celle utilisée lors de l’importation.
-
D’abord, dans l’onglet Format de base, cliquez sur le bouton radio séparé par des virgules ou des tabulations.
-
Ensuite, cliquez sur l’onglet des options séparées par des virgules ou des tabulations.
Ici vous pouvez:
-
Choisir un encodage: Par défaut, memoQ détecte l’encodage (la page de codes) des fichiers que vous importez. Si l’encodage ne peut pas être détecté, memoQ utilise Unicode (UTF-8). Pour utiliser un encodage différent, sélectionnez-le dans la liste déroulante « Page de codes si non détectée ».
-
Exportez la traduction dans un encodage différent: Si l’encodage source n’est pas Unicode et que vous traduisez vers une langue utilisant un système d’écriture différent (par exemple, de l’anglais vers le japonais), choisissez un autre encodage pour la traduction dans la liste déroulante ’exportation.
-
Décider de la gestion des BOM(marques d’ordre desoctets) qui peuvent apparaître au début d’un fichier texte et signaler l’encodage du texte. Vous pouvez :
-
Ajouter une nomenclature aux traductions si le fichier source en contient une : Laissez le paramètre par défaut (Identique à l’original).
-
Ajouter une nomenclature à toutes les traductions exportées Sélectionner Ajouter la BOM à tous les fichiers.
-
Exporter toutes les traductions sans nomenclature d’octets (BOM) : Sélectionner Ne pas ajouter de BOM à un fichier.
-
-
Choisissez le caractère qui sépare les colonnes: Par défaut, memoQ utilise le caractère de tabulation. Vous pouvez cliquer sur les boutons radio pour choisir d’autres caractères séparateurs courants(virgule ou point-virgule). Si votre fichier utilise un autre séparateur, cliquez sur le bouton radio Autre et saisissez le caractère dans la zone de texte.
-
Regardez l’aperçu: En bas de la fenêtre, vous pouvez voir comment memoQ importerait votre fichier avec les paramètres actuels. Vérifiez si les caractères apparaissent correctement et si les colonnes sont séparées correctement. Si vous importez plusieurs fichiers, memoQ affiche l’aperçu du premier fichier. Si elle est trop petite ou si le résultat ne s’affiche pas clairement, choisissez un autre fichier à prévisualiser : Cliquez sur Charger l’aperçu à partir du fichier d’échantillon, puis choisissez le fichier à utiliser pour l’aperçu.
-
Y a-t-il des guillemets doubles ou des sauts de ligne dans le fichier CSV? La spécification CSV a des exigences compliquées pour le traitement de ces caractères (voir section 2., points 5., 6. et 7 du document lié). Si un fichier CSV ne répond pas à ces exigences, memoQ corrige les problèmes avant l’exportation. Cela signifie que les fichiers importés et les fichiers exportés seront différents. Gardez cela à l’esprit si vous utilisez des fichiers CSV non standard.
Utilisez toujours cela dans les projets bilingues: Si votre projet n’a qu’une seule langue cible, ou si vous utilisez memoQ Translator Pro, utilisez toujours ce paramètre.
-
Sur l’onglet Format de base, sous Sélectionner le format de base, cochez la case de configuration simple bilingue. Une sectionColonnes apparaît au bas de l’écran.
-
Choisissez la colonne qui a le texte source: Dans la zone de texte Source, tapez la lettre de la colonne.
-
Choisissez la colonne où la traduction devrait aller: Dans la zone de texte de traduction, tapez la lettre de la colonne.
-
Choisissez la colonne qui a les commentaires: Dans la zone de texte Commentaires, tapez la lettre de la colonne.
-
Choisissez la colonne qui a les ID de contexte: Dans la zone de texte contextuelle, tapez la lettre de la colonne. memoQ utilise le contenu de cette colonne pour les correspondances en contexte et retourne des correspondances exactes en contexte à partir des mémoires de traduction ou des bases LiveDocs.
Si le tableau a un segment d’en-tête, et que vous ne voulez pas l’importer: Vérifiez la case à cocher "La première segment contient les noms de colonnes".
Si la colonne Traduction contient déjà des traductions, memoQ les importe comme texte cible. Si vous ne voulez pas les importer, décochez la case « Importer le texte cible ».
Projets multilingues seulement: Utilisez ce paramètre uniquement dans l’édition memoQ pour chefs de projet et seulement lorsque vous préparez un projet multilingue pour plusieurs traducteurs.
Exportation MQXLIFF pour une langue cible à la fois: Le format MQXLIFF est bilingue - il a une langue cible. Dans le projet, vous devez sélectionner une langue cible avant d’exporter un document multilingue en MQXLIFF. L’exportation MQXLIFF de tels fichiers aura cette langue cible.
- Sur l’onglet format de base, assurez-vous que la case à cocher Configuration simple bilingue est décochée.
- Sur l’onglet Colonnes, définissez la signification de chaque colonne sélectionnée.

-
Choisissez l’état des segments qui ont déjà des traductions. Par défaut, il est défini comme modifié, mais vous pouvez choisir un autre état dans la liste déroulante « Si l’entrée contient du texte dans la langue cible ».
Si le tableau a un segment d’en-tête, et que vous ne voulez pas l’importer: Vérifiez la case à cocher "La première segment contient les noms de colonnes".
Ignorer le texte cible qui est déjà présent: Si l’entrée contient le menu déroulant de la langue cible, choisissez Ne pas importer.
Les cellules ne sont jamais segmentées. Si une cellule dans le tableau contient plusieurs phrases, celles-ci seront importées dans un seul segment.
Mettre en place des colonnes
memoQ liste toutes les colonnes de votre fichier, et définit leur signification à Non importé. Au début, seules les 26 premières colonnes sont visibles. Pour en voir plus, cliquez sur le lien Ajouter 26 colonnes.
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez texte source.
Si un segment source dans une segment est vide ou ne contient que des espaces, memoQ n’importera pas cette cellule, ses traductions, contextes et commentaires.
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez Traduction.
- Dans le menu déroulant pour la colonne, choisissez l’une des colonnes qui sont déjà marquées comme texte source. S’il n’y a qu’une colonne qui contient du texte source, la liste ne contiendra que cette colonne.
- Dans le menu déroulant Langue, choisissez la langue cible de la colonne. Vous pouvez choisir n’importe quelle langue que memoQ prend en charge. Mais si le projet n’a pas cette langue, la colonne ne sera pas importée.
Si vous ne choisissez pas une langue: La colonne sera réglée sur traduction remplaçant la source.memoQ importe cette colonne comme texte source, et remplace ce texte source par la traduction.
Définir une colonne comme contexte pour la correspondance:
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez Contexte.
- memoQ utilise les cellules de cette colonne comme ID de contexte pour les cellules de texte source qui se trouvent dans le même segment.
Vous pouvez choisir plusieurs colonnes en contexte: Dans ce cas, memoQ les additionnera à la fin de votre document et utilisera le résultat comme contexte.
Pour définir une colonne comme commentaire:
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez Comment.
- Dans le menu déroulant Pour la colonne, choisissez la colonne à laquelle ce commentaire appartient. Vous pouvez également choisir Tout:memoQ importe ce commentaire pour chaque segment dans le même segment.
Vous pouvez importer un commentaire différent pour chaque colonne source et colonne cible.
Si vous ne souhaitez pas importer tous les segments d’un fichier, vous pouvez définir des conditions pour exclure des données spécifiques.
Pour cela :
-
Dans la liste, sélectionnez la colonne qui contient les valeurs que vous souhaitez évaluer.
-
Dans Signification de la colonne sélectionnée, choisissez Condition.
-
Dans la colonne Pour, sélectionnez la colonne à laquelle cette condition s’applique.
Vous pouvez également choisir Tout pour appliquer la condition à l’ensemble du segment.
-
Dans Ne pas importer ces éléments, saisissez une ou plusieurs valeurs (mots ou expressions) qui devraient empêcher l’importation.
Comment ça fonctionne :
-
Entrez plusieurs valeurs en les séparant par des virgules, sans espaces.
Par exemple : erreur, ignoré, invalide
Si un espace est ajouté après une virgule, memoQ ne prend en compte que la première valeur.
-
Si une valeur contient une virgule, mettez-la entre guillemets.
Par exemple: "New York, NY"
-
Si le contenu d’une cellule de condition correspond à l’une de ces valeurs, il ne sera pas importé.
-
Si vous avez sélectionné Tout pour appliquer la condition à l’ensemble du segment, memoQ ignore tout le segment.
-
Votre fichier peut avoir des limites de longueur - contenir une colonne avec des nombres. Cela signifie que les traductions ne peuvent pas être plus longues que le nombre indiqué dans la colonne.
Utiliser les limites de longueur:
- Dans la liste, sélectionnez la colonne qui a les limites de longueur.
- Dans le menu déroulant de la colonne sélectionnée, choisissez limite de longueur (caractères ).
- Dans le menu déroulant Pour la colonne, choisissez à quelle colonne cette limite de longueur appartient. Si vous choisissez une colonne cible, memoQ utilise les limites pour ces cellules. Si vous choisissez une colonne source, memoQ utilise les limites pour toutes les traductions qui appartiennent à cette colonne source.
Par défaut, memoQ affiche chaque champ pertinent dans l’aperçu.
Si vous voulez cacher une ou deux colonnes de l’aperçu:
-
Sélectionnez la colonne dans la liste.
-
Ensuite décochez la case Afficher dans l’aperçu.
Le résultat ressemblera à ceci:
- Sur l’onglet format de base, assurez-vous que la case à cocher Configuration simple bilingue est décochée.
- Sur l’onglet Colonnes, définissez la signification de chaque colonne sélectionnée.
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez texte source.
Si un segment source dans une segment est vide ou ne contient que des espaces, memoQ n’importera pas cette cellule, ses traductions, contextes et commentaires.
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez Traduction.
- Dans le menu déroulant pour la colonne, choisissez l’une des colonnes qui sont déjà marquées comme texte source. S’il n’y a qu’une colonne qui contient du texte source, la liste ne contiendra que cette colonne.
- Dans le menu déroulant Langue, choisissez la langue cible de la colonne. Vous pouvez choisir n’importe quelle langue que memoQ prend en charge. Mais si le projet n’a pas cette langue, la colonne ne sera pas importée.
Si vous ne choisissez pas une langue: La colonne sera réglée sur traduction remplaçant la source.memoQ importe cette colonne comme texte source, et remplace ce texte source par la traduction.
Pour définir une colonne comme heure de début ou heure de fin pour le segment:
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez l’estampille temporelle du sous-titre ou l’ horodatage de fin des sous-titres, selon vos besoins.
Pour définir une colonne comme limite de longueur:
- Sélectionnez la colonne dans la liste.
- Dans le menu déroulant de la colonne sélectionnée, choisissez limite de longueur (caractères ).
-
Dans le menu déroulant Pour la colonne, choisissez à quelle colonne cette limite de longueur appartient. Si vous choisissez une colonne cible, memoQ utilise les limites pour ces cellules. Si vous choisissez la colonne source (elle a "(toutes les traductions)" à côté), memoQ utilise les limites pour toutes les traductions.
Faites cela dans l’onglet Sous-titres.
Lorsque vous travaillez sur une traduction vidéo, il est important de savoir combien de texte vous pouvez mettre à l’écran à la fois.
Modifiez au besoin la valeur du champ Limite de longueur de ligne (caractères ), soit la limite de caractères pour la longueurdes lignes.
La densité signifie combien de texte est affiché sur l’écran au fil du temps. Vous pouvez définir des limites pour les mots par minute et les caractères par seconde - les deux mesures les plus courantes.
Aucun avertissement dans memoQ lui-même pendant la traduction: lorsque vous confirmez un segment, memoQ ne vous avertit pas si vous dépassez ces limites. Vous voyez quelles lignes sont plus longues que la limite seulement lorsque vous exportez le fichier.
Cependant, l’outil d’aperçu vidéo memoQ affiche toutes les trois valeurs en temps réel lors de la lecture de la vidéo:
« En ligne » signifie un fichier sur un serveur: Pour le moment, les services de diffusion en continu tels que YouTube ne sont pas pris en charge.
Lorsque vous avez terminé
-
Pour confirmer les paramètres et revenir à la fenêtre Options d’importation de documents: Cliquez sur OK.
Dans la fenêtre Options d’importation de documents: Cliquez à nouveau sur OK pour commencer l’importation des documents.
-
Pour revenir à la fenêtre des Options d’importation, et ne pas changer les paramètres du filtre: Cliquez sur Annuler.
-
Si c’est un filtre en cascade, vous pouvez modifier les paramètres d’un autre filtre dans la chaîne : Cliquez sur le nom du filtre en haut de la fenêtre.
Il est possible de cascader des filtres après les filtres bilingues et multilingues. Par exemple, textes ,textes multilingues Excel et textes délimités peuvent être le premier filtre dans une chaîne de filtrage, mais n’oubliez pas que le Module de balisage RegEx doit toujours être le dernier filtre appliqué.